Enums
suggest changeUse a singular name for most Enums
public enum Volume
{
Low,
Medium,
High
}
Use a plural name for Enum types that are bit fields
[Flags]
public enum MyColors
{
Yellow = 1,
Green = 2,
Red = 4,
Blue = 8
}
Note: Always add the FlagsAttribute
to a bit field Enum type.
Do not add ‘enum’ as a suffix
public enum VolumeEnum // Incorrect
Do not use the enum name in each entry
public enum Color
{
ColorBlue, // Remove Color, unnecessary
ColorGreen,
}
Found a mistake? Have a question or improvement idea?
Let me know.
Table Of Contents